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Introduction 
 

About nmCollector.Net LLC 

 

nmCollector.Net LLC is a New Mexico based company that was officially licensed in April of 2001 to develop and sell collecting software over 
the internet.  Our flagship product is NM Gun Collector Software which was developed specifically for gun collectors and runs only on 
Microsoft Windows operating systems.   It has been carried by many well known distributors including Brownells.  Our current efforts are 
focused around a more general product applicable to any collection which can be run on any computer operating system.  This product is 
called NM Collector Software JE (Java Edition). 
 

 

Contacting Us 

 

email: cjpryor@nmcollector.net 
 

web contact form: http://www.nmcollector.net/nmguncollector/contactForm/feedback.php 
  
physical address: 

Clayton J. Pryor 
C/O R. B. White, P.C. 
9007 Washington NE 
Suite A 
Albuquerque, New Mexico 87113 

 

NM Collector Software JE 

About 

 

NM Collector Software JE (Java Edition) is a truly portable software designed to be run on any computer with any operating system from a 
USB Flash drive. Although it can be installed on the computer hard drive it is also designed to run entirely off of a USB flash drive that can be 
plugged into any computer making it a truly portable application. 
 

* Java 6 run-time engine required - comes with Windows, Mac OS, and Linux 
 

In addition to well defined fields for gun collections there are also templates for coin collections, knife collections, Japanese sword 
collections, stamp collections, gem collections and others.  You can even define your own collection types from scratch if you wish.  If you 
have suggestions for what to include for any collection type please let me know so I can make them available to others. 
 

With NM Collector Software JE you can customize to your preferences: 
 

    * Look and Feel - pick and choose your own Fonts including style and size as well as foreground and background colors. 
    * Field Headings - standard headings available which you can modify and/or make your own. 
    * Drop Down Values - many provided for each type of collection but you can add and modify your own. 
    * Collection Type Templates - many are provided and you can create your own. 
    * More ...  see for yourself what you can do ... 
 

If you do not like the fields provided you can redefine them to your own.  You get over 32 fields that you can define. 
 

 

Overview 

 

The NM Collector Software JE user interface is broken down into two major components;  a tree view and tabs. 
 

The tree view provides your main interface to entire contents of your collection. Using the tree view you can add, delete, and select items to 
view and update. You can also modify their location relative to other items in the tree view.  It also provides you with a means to search large 
collections for specific items. 
 

The tabs provide a means for organizing, viewing, and updating data specific to the individual item selected in the tree view.  There is room 
for a lot of data so the tabs provide a logical and intuitive organization for that data. 
 

 



Tree 
 

Overview 

 

The tree view is your main tool for organizing your collection and selecting the items you wish to edit.  Following the screen capture below is 
a description of the tree functionality.  Please see my examples web page (http://www.nmcollectorsoftware.com/examples/) for ideas on how 
to use this tree. 
 

 
 

As you can see from this excerpt, we can view all or parts of our collections in this tree view.  Collection types are shown as a special "NM" 
folder while items in the collection type are listed under the collection type.  Some items themselves look like folders while others look like a 
simple sheet of paper.  More on this later under "Sub Folders" (below). 
 

The buttons at the top are enabled and disabled as appropriate to where we are in the tree.  In this case we have a collection type (Firearms) 
selected so only buttons that apply to an entire collection type are enabled.  At this point it makes sense to Find an item in the collection or to 
Insert (Ins) a new item in the collection.  More on the buttons later.   
 



Select an Item 

 

 
 

In the picture above we have selected an item to edit.  The values for the selected item are populated in the tabs for easy viewing and 
editing.  Also note that all of the buttons above the tree are now enabled.  All of them make sense when an individual item is selected. 
 

Drag and Drop 

 

At this point it makes sense to discuss dragging and dropping items in the tree view.  You can move an item to any location you wish by 
simple clicking on it and holding the mouse button while you move it in the tree then letting go of the mouse button where it is where you 
want it.   
 

Sub Folders 

 

As noted above, some items look like folders while others don't.  You can create sub folders to associate items with other items or to collect 
items for whatever reason makes sense to you.  To convert an item to a sub folder simply select it and click the "Ins" button to insert a new 
item to be associated with it or "Demote" (Dem) the item located directly below it.  Now you can add other items to the folder by inserting new 
items in the sub folder or dragging and dropping other items to it.  Notice that the sub folder still retains it's identity as an item so you can 
manage information about it or, if it makes sense, you don't need to manage any information about it.  An example of a folder that would not 
require any data would be a location folder (such as bedroom safe) created simply to manage the location of items. 
 

Buttons 

 

Now is the time to discuss the functionality of each individual button. 
 

Find - locate any item in the tree based on a text value in one of the first Identification fields.  This is particularly useful for large collections. 
 

Dup (Duplicate) - create a new item based on the currently selected item. All relevant ID, Description, Receipt, and Disposition data will be 
copied. This is particularly useful if you acquire many similar items at the same time.  Be sure to change something immediately after the 
duplication so as to distinguish the items one from another. 
 

Ins (Insert) - create a new item from scratch.  If a collection is selected when the Ins button is pressed, the new item will be inserted as a 
member of that selected collection.  If an item is selected when the Ins button is clicked the currently selected item will be converted to a 
folder and the newly inserted item will be automatically associated with that item.  If this is not your intent you can use the Dem (Demote) 
button below to make the newly inserted item an equivalent to the selected item. 
 

Del (Delete) - delete the current item.  Be careful with this as there is no recovery unless you recover your database from backup. 
 

Pro (Promote) - promote (shift left) the selected item. 
 

Dem (Demote) - demote (shift right) the selected item. 
 

 



Tabs 

Buttons 

 

There are buttons at the top of each tab.  The actual buttons vary by tab.  When a button is not enabled that means it does not apply to the 
current situation.   
 

 
 

The function of the buttons is as follows: 
 

Clear - clears the contents so you can start from scratch. 
 

Revert - if changes have been made on the current page, this button is enabled.  It allows you to revert your data to the last saved values. 
 

Save - if changes have been made on the current page, this button is enabled.  It saves the current values. 
 

Statistics - this takes you to the Statistics page.  
 

Close - closes NM Collector Software JE. 
 

 

Identification 

 

This tab is used to capture identification information. 
 

 
 

Captions are initially populated based on the collection template selected.  These captions can be customized to your preferences.  Of 
course, changing a caption within a collection type will apply to all items within that collection type.  More on that under Edit Captions. 
 

All fields are editable so use them as you wish.   Where there are drop down lists, an existing item can be selected or new items can be 
added simply by typing a new value in the drop down field.  The next time you need the item it will appear in the drop down and can be 
selected. 
 

The bar code is an automatic conversion of the Unique ID into a bar code.  This field can be used to quickly locate an item based on a scan 
of the bar code.  For example, you can print bar codes to hang tags and tie them to each of your items.  While inspecting an item you can 
scan the bar code into this bar code field and the system will immediately locate and make that item current. 
 

 



Description 

 

This tab is used to capture descriptive information that is in addition to basic identification information. 
 

 
 

As with the identification tab, captions can be changed and all fields are editable. The dates expect the following format:  "MM/DD/YYYY" 
and will not be captured if that format is not used. 
 

 

Pictures 

 

This tab is used to capture detailed pictures of the selected item. 
 

 
 

This page should be self explanatory.  it is important to note that although the original Picture Path is displayed the actual picture is loaded 
into the database. Whenever the picture is displayed it is brought in from the database not the file system. 
 



Also, if the pictures are too large they can affect the performance of the application and may not load properly or show up in reports with 
images.  Please keep them as small as reasonably possible.  I have successfully loaded pictures as large as 2048 x 1360 pixels (1,400 KB) 
with no problems. 
 

 

Receipt 

 

This tab is used to capture information on your acquisition of the item. 
 

 
 

There can be multiple receipts for any item since an item can be disposed of and then brought back into the collection for one reason or 
another. 
 

 

Disposition 

 

This tab is used to capture information on your disposition of the item. 
 

 
 



There can be multiple dispositions for any item since an item can be disposed of and then brought back into the collection for one reason or 
another and then disposed of again. 
 

 

Maintenance 

 

This tab is used to capture maintenance and repair that has been performed on the selected item. 
 

 
 

The intent of the Increment and Units field is to identify the interval (other than date) at which the operation was performed and is to be 
performed next.  For example, if you were to change the oil in your car every 3 months or three thousand miles, your Completed Increment 
would be the actual miles at which the oil change was performed and the Units would be miles.  The Next due date would be three months 
later and the Next Due increment would be the current increment plus 3000 miles. 
 

 

Events 

 

This tab is used to capture events such as shows and outings with the item. 
 

 
 



This should be self explanatory. 
 

 

Data Sheets 

 

Some advanced collectors, particularly with regard to many U.S. military firearms, require extensive detailed documentation of the 
components found within an item.  There is no way to capture these details other than through the use of a Data Sheet designed specifically 
for that item.  Images of data sheets can be captured in the pictures section.  However, this tab allows a person to enter textual data sheets 
that can be reviewed and updated as appropriate. 
 

Here is an example of a blank M1 Garand Data sheet. 
 

 
 

 

More 

 

Capture even more descriptive information here.  Many more fields are provided for your customization. 
 

 
 



Please note the pre-defined field types including Text (with drop downs), Currency, Date, and Notes.  These field types come with certain 
pre-defined expectations for that field type so please use the appropriate field type for your data. 
 

 

Edit Captions 

 

Captions can be changed to meet your needs on any tab simply by checking "Edit Captions" and making your changes.  Uncheck "Edit 
Captions" when you are done. 
 

 
 

 

Menu 
 

File 

 

Backup Database 

 

There are many ways to backup your database in case of data loss.  This is one of them.  Others can be found in our Best Practices support 
Forum at http://www.nmcollector.net/forum. 
 

To Backup your data: 
 

a. From the main menu, select "File > Backup Database" which will present you with the following window.  
 

 
 

This window is a bit confusing because I want you to select a directory and I restrict what gets displayed to directories only, but due to a 
known Java bug, it asks you to specify a "File Name."  ( if interested, please see the following url for more information on the bug: 
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6438246),  



 

b. Navigate to the backup location of your choice. You can create a new directory if you wish. Here I have created and selected a directory 
named NMCollectorJE_DB_BU in the existing C:\BU directory path. 
 

 
 

c. Once you have selected your desired backup location simply click the Save button to create the back up in that location. The backup is 
named, simply enough, "nmcswDB_backup." 
 

 

Recover Database 

 

Hopefully you will never need your backup. However, if the occasion ever presents itself in which you have to recover your data, just follow 
these steps. 
 

 

To Recover your data: 
 

a. From the main menu, select "File > Recover Database" which will present you with the following window. Again, it is a bit confusing as 
indicated above in that it asks for a File Name when you really just need to select a directory. 
 

 
 

b. Navigate to the backup directory that you saved your backup to. As shown below, select the file named "nmcswDB_backup" that was 
created for you when you backed up your data. 
 

 



 

c. Once your recovery database is selected, simply click the "Open" button and it will be loaded. 
 

You will have to restart NM Collector Software but once you do your data will be recovered. 
 

 

Import > NM Gun Collector Data 

 

This menu item has one purpose - to facilitate the migration of data from NM Gun Collector Software to NM Collector JE.  Additional 
information can be found at http://www.nmcollectorsoftware.com/support/Import.htm. 
 

 

Security 

 

You can set a password and enable security to prevent others from using your copy of NM Collector Software.  Be sure to put the password 
in a safe place for you will need it to use NM Collector Software after you enable security! 
 

 

Manage 

 

Manage Collection Types 

 

Use this functionality to add, delete, or change Collection Types. 
 

 
 

 

You can edit values (other than the ID which is set for you and maintained by the system) by clicking a value within the table and typing 
within that cell.  The "Show in Tree" checkbox determines whether or not the Collection Type will be displayed in the tree. 
 

The following is a description for each button: 
 

Resynch - used to update the main tree view with your changes.  This will also happen automatically when you close the Collection Types 
window. 
 

Export - use this button to export the selected collection.  You select a collection for export by clicking the name prior to clicking the Export 
button or from a drop down after you have clicked the Export button.  This can be used to share your collection type definition with others. 
 

Import - use to import an exported collection type.  If the name of the imported collection type already exists it will be renamed prior to import 
so as not to over write your current definition. 
 

Insert - use to create a new collection type.  Once created go to the main tabs to set the headings. 
 

Delete - delete the selected collection type. 
 

Print - print the table of collection types. 
 

Close - close the Collection Types window. 
 

 



Edit Drop Down Lists 

 

Use this functionality to edit drop down lists on each tab. 
 

 
 

 

Select the Collection Type from the drop down and then the list you want to edit from the other drop down list.  These lists are automatically 
populated as you add new values to the drop downs on each tab.  Sometimes you will unintentionally add an item that does not belong or 
need to correct the spelling.  Use this tool to make those corrections. 
 

 



Format 

 

Use the Format menu to change the default formats for buttons, captions, and fields.  Here is an example for fields: 
 

 
 

You can change the font type, font color, and background color.   
 

You can also change individual items by double right clicking the item and selecting the appropriate values to change form the pop up menu.  
Here is an example of a special format applied to a key identification field: 
 

 
 

 



Reports 

There are many reports available.  You can select them through this menu item. 
 

 
 

If you need a report that you can not find, please let us know what that report is so we can develop it for you and others. 
 

 

Subscription 

 

Manage your subscription here.  If you purchase a lifetime subscription you need only enter it once and never again after that. 
 

 
 

Use Edit > Paste to simplify entry of the subscription information. 
 

 

Help 

 

Various links to help are provided here. 
 

 



Statistics 

 

This tab can be your best friend if you have a large collection.  It is also extremely useful if you track purchase, sale, and appraised values as 
it will summarize total cost and values for you. 
 

Make changes here or double click on an item in the table to go to it in the main window.  Export the data in various forms including HTML, 
XML, and CSV (for importing into Excel).  The Refresh button is used to update any changes made here in the main window. 
 

 
 


